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SOFTCHALK CLOUD  

The SoftChalk program is accessed through an Internet website called SoftChalk Cloud, or Cloud for 

short.  Cloud is NOT used to create or edit lesson content, but it does contain the link to the program 

used for these actions.  Cloud is an online storage facility used to hold activities and lessons.  

 

IMPORTANT NOTE:  SoftChalk requires the Java program to be installed on your computer.  

Unfortunately, Google Chrome has changed the way it handles Java and starting with the Version 42 

(April 2015) of Google Chrome, Java has been disabled in this web browser.  Please avoid using Chrome 

when working with SoftChalk. 

Acquire a Cloud Account 

1. Use a web browser (not Chrome) to open:  www.softchalkcloud.com 

2. At the top of the screen, click the Join Now link. 

3. Fill out the form as needed.  See the note below. 

NOTE:  Account Type = SoftChalk Cloud (I have an activation key) 

a. Key = zYFkJRomWTM870B6bAKi 

4. Add checkmarks to BOTH “I agree…” boxes, located at the bottom of the form. 

5.  

NOTE:  At this point, you will be logged in to your new SoftChalk Cloud account 

 

  

  

http://www.softchalkcloud.com/
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Create Folders in your SoftChalk Cloud Account 

After acquiring a Cloud account, it is suggested to create some folders into which lesson activities can be 

uploaded.  Most instructors create folders named after the courses in which the activities will be placed.  

For example, I could have a folder named, “BIOL-2314.”  

 

1. If SoftChalk Cloud is not already open, use a web browser (not Chrome) to open the 

http://www.softchalkcloud.com web page. 

2. At the top of the page, click the Login link. 

3. Supply your username and password to login to the account. 

NOTE:  When you login to Cloud, your profile information is displayed and an Edit Profile link is 

provided at the right side of the screen which allows you to easily change profile information if 

needed. 

4. As illustrated below, on the gray toolbar at the top of the page, click  

My Content > My Learning Objects 

 

5. Create folders to contain lesson activities: 

a. At the right side of the screen, click the “Create Folders” link.  This will open a dialog box. 

b. Type a name for the new folder. 

c. Click the  button. 

6. Repeat the previous steps for all new folders to be created. 

  

  

http://www.softchalkcloud.com/
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INSTALLING “SOFTCHALK CREATE” 

There are two ways in which you can use “SoftChalk Create” to build content: 
1. Use Cloud to install a version of Create onto the computer 

2. Use a link in Cloud to run a virtual session of Create.  This does not load software onto the 

computer. 

Install SoftChalk Create onto the Computer 

1. Use the directions in the previous section of this manual to login to your Cloud account. 

2. As illustrated below, on the gray toolbar at the top of the page, click  

My Content > My Lessons & Courses 

 

3. Click the  link located at the right side of the screen.   

4.  (or use the Mac version if needed) 

5.  
6. Locate the file which was download to your computer.  Most likely, this file was saved in the 

Downloads folder on your computer. 

7. Double-click the file (SoftChalk-Local-Launch_Setup.exe) to run the file. 

8.  
NOTE:  You may get a warning message from the virus checking software.  Choose to allow the 

file to be run. 

9.  

10.  

11.   This will open a dialog box in which you type your username and password (created 

earlier in the SoftChalk Cloud account). 

12.  
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BUILD A NEW SOFTCHALK LESSON 

Since the directions in this part of the manual require an account in SoftChalk Cloud, follow the 
directions in the first part of this manual to create a Cloud account if needed. 

Launch the SoftChalk Create Program 

SoftChalk Create is the name of the software used to actually create the lesson content. 
 

1. Use a web browser (not Chrome) to login to your Cloud account. 

2. As illustrated below, on the gray toolbar at the top of the page, click  

My Content > My Lessons & Courses 

 
 

3. Click the  link located at the right side of the screen.   

4. On the “Opening JNLP” dialog box, click the  button. 

5. Click the  button to launch the program. 

6. Update SoftChalk if prompted. 

 

Add Text 

1. Use the directions in the previous section of this manual to login to the Cloud account and launch 
the Create program. 

2. Put text into the lesson: 

a. Type an introductory paragraph from the keyboard, or 

b. Copy/Paste text from a MS Word document or  

c. Copy/Paste text from a web page 
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Insert an Activity 

This example shows how to add a “Did You Know” activity.  This activity displays a question and allows 
the students to click on a link to display the answer. 
 

1. Open the SoftChalk lesson. 

2. Place the cursor in the location where the activity is to be inserted. 

3. Click Insert > Activity > DidYouKnow  

a. Use the drop-down arrow for the Icon field to choose the graphic to be used to signify an 

activity. 

b. In the upper Question field, type a question for the students. 

c. In the Reveal Label field, either keep the default text or add new text such as,  

“Click here to find out.” 

d. In the Answer field, type the answer to the question. 

4. Read the Question and the Answer carefully to look for spelling errors.  They are not marked like 

they are in MS Word. 

5. On the Options tab: 

a. Type any new directions for the students if needed. 

b. In the “Activity Display” area, specify how the activity is to be activated by the student.  

NOTE:  The “Display Inline” is the most popular option chosen. 

6.  
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Build a Test 

SoftChalk has testing capabilities built into it.  These can be used to test your students instead of using 
the testing capabilities in Blackboard. 
 

1. Place the cursor where the test is to be displayed. 

2. Click Insert>Quiz Group. 

3. In the Group Name field, type a name for the test. 

4. Add test questions: 

a. Use the drop-down arrow to select the type of question. 

b. Click the ADD button. 

c. Fill out the form.  This form will be different depending on the question type. 

d. Make sure you specify the correct answer. 

e. On the Feedback tab, add feedback if desired 

f. On the Hint tab, add a hint if desired 

g. On the Options tab, specify how many points this question is worth. 

h.  

5. Repeat the previous step (and sub-steps) for each question to be added to the test. 

6. On the Group Options tab, fill out the options as needed. 

7.  
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Save a SoftChalk Lesson 

Saving the lesson saves everything inside it.  Activities do not have to be saved individually, although 

they have to be uploaded into the Cloud individually.  When a lesson is saved, there are many files and 

folders which get saved, not just the simple screen seen on the monitor. 

 

1. Save the lesson onto your local computer: 

a. On the File menu, click Save As  

b. Save In field:  Use the drop-down arrow to select the drive and folder in which you want 

your lesson to be stored. 

c. File name field:  Type a name (cannot contain spaces) for the new lesson. 

d.  
 

2. Save to lesson into SoftChalk Cloud: 

a.  On the File menu, click Save to SoftChalk Cloud  

b. Save In field:  Use the drop-down arrow to select the drive and folder in which you want 

your lesson to be stored. 

c. Item name field:  Type a name for the new lesson. (spaces ARE allowed) 

NOTE:  At the right side of the dialog box, make sure My Lessons & Courses is highlighted.  
This is the location where the lesson will be saved. 

d.  

e.  

f. Click the  button. 

 

  



 

Page 8 
 
 

UPLOAD A SOFTCHALK ACTIVITY INTO THE CLOUD  

This activity is done when a SoftChalk activity has been created in a lesson saved onto the computer’s 
hard drive and not in the Cloud. 
 

Upload the Activity 

This process copies a single SoftChalk activity into the Cloud account where it can then be displayed in a 
Blackboard course. 
 

1. If a folder has not been previously created in your Cloud account, do that first before continuing 

with this activity.  Directions for this process are on page two of this user manual. 

2. Open a previously-created lesson or build a new lesson. 

3. Make sure the lesson contains an activity (ex:  Did-You-Know, Sorting, or WordSeek). 

4. Right-click the activity and choose “Save to SoftChalk Cloud.” 

NOTE:  A window will open displaying Cloud folders and content. 

a. At the right side of the window, click the folder into which the activity is to be saved.  

b. In the Name field, type a name such as, “Lesson 1 - Understanding Galaxies.”  

c. Add a description if desired. 

d.  

e.  

f.  

NOTE:  The activity is now stored in the SoftChalk Cloud account and it can then be 

displayed in various Blackboard courses. 
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Get the Embed Code 

The embed code is special coding which allows an activity to be stored in the Cloud, but displayed inside 

a Blackboard course. 

 

1. Follow the previous directions to upload a SoftChalk activity into the Cloud. 

2. If needed, login to your SoftChalk Cloud account. 

3. As illustrated below, on the gray toolbar at the top of the page, click 

My Content > My Learning Objects 

 

 

4. From the list of folder, click the folder containing the desired activity. 

5. Click on the desired activity to open it. 

6. In the lower-right corner of the web page, click on the Embed code to highlight it. 

NOTE:  The embed code will start with, “<iframe width=” 

7. Use CTRL+C to copy the highlighted embed code. 

 

  



 

Page 10 
 
 

Embed the Activity into Blackboard 

Once the embed code has been copied for an activity, it has to be embedded into an “iFrame” in a 

Content Folder in a Blackboard course.  This iFrame will display the activity even though the activity is 

physically stored in the Cloud. 

 

1. Complete the instructions from the previous sections of this manual to upload an activity into the 

Cloud and then copy the embed code for the activity. 

2. In Blackboard, open the course in which the activity is to be displayed. 

3. Open a Content Area (such as Content or Lessons)  

4. If needed, open or create a Content Folder where the activity is to be displayed. 

5. Create a place for the activity to be displayed: 

a. Rest the mouse pointer on the  button and then make a decision as to how 

you want the students to open the activity: 

i. Item – the activity automatically loads without the student needing to click on 

anything to activate it. 

ii. Blank Page – a link is inserted into the folder on which the students have to use 

the mouse to activate the activity. 

b. Name the “item” or “blank page” as needed. 
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6. In the Text field (if an item is being created) or the Content field (if a blank page is being 

created), do the following: 

a. As shown in the illustration below, click the  

“Insert/Edit Embedded Media”  icon 

 

 

 

 

b. In the Type field, use the drop-down arrow to change Flash to “iFrame” 

c. Click the “Source” tab 

d. Erase the contents and replace with the copied embed code from the previous section of 

this direction list. 

e. Click the “General” tab and wait until the activity loads.  

f. Click the INSERT button (lower-right corner) 

g. From the keyboard, press the ENTER key twice 

h. SUBMIT to save the Bb page. 

NOTE:  At this point, the activity should be seen in the folder. 
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UPLOAD AN ENTIRE SOFTCHALK LESSON INTO THE CLOUD 

The process of uploading an entire SoftChalk lesson is a little more complex than simply loading 

individual activities.  It requires the instructor to copy an “LTI Hyperlink” which uses a unique connect 

which allows a grade to be automatically sent from SoftChalk into the Bb gradebook if desired. 

Sync SoftChalk  

If this procedure has not been done before, it needs to be completed before trying to upload a SoftChalk 

lesson into the Cloud account. 

1. Use SoftChalk Create to open a previously-created lesson, or build a new lesson. 

2. Sync SoftChalk Create to your SoftChalk Cloud account: 

a. File > Manage Publish Accounts. 

b. If your account name is already in the list and the type is SoftChalk Cloud, your programs 

are already synced together and you can skip to the “Save the Lesson into the Cloud” 

section on the next page of the manual. However, if your account name is not in the list: 

i. Click the NEW button 

ii. Highlight SoftChalk Cloud 

iii.  

iv. Enter your SoftChalk Cloud username and password. 

v. Check “Prompt me for my password when publishing” for security. 

vi.  

vii.  
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Save the Lesson into the Cloud 

3. Complete the directions in the previous section of this manual to sync Create and Cloud. 

4. In SoftChalk Create, open the lesson to be uploaded. 

5. Click File > Save to SoftChalk Cloud. 

6. If prompted, enter your password and click . 

7. In the Repository area at the right side of the window, select the folder (pg. 2) in which to save 

the lesson.  

8. In the “Item Name” field, type a name for the lesson being saved in the Cloud. 

9. If it is not already selected, click the Personal option button. 

10. SAVE. 

11. After you receive a message saying the lesson was saved to SoftChalk Cloud, click . 

12.  

13. Minimize or close SoftChalk Create. 

Copy the LTI Hyperlink of the Lesson (stored in the Cloud) 

After the lesson has been saved into Cloud, a code called an “LTI Hyperlink” needs to be copied from the 

lesson in Cloud so it can be used to open a “Web Link” in Blackboard. 

14. Use a web browser such as Firefox to open SoftChalk Cloud. 

15. Login to your SoftChalk Cloud account. 

16. In SoftChalk Cloud, click My Content > My Lessons & Courses 

17. Click on the name of the lesson you want to display in Blackboard. 

18. Scroll down below the lesson. 
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19. In the “Share” area (right side of screen), copy one of the following: 

a. Copy the “Hyperlink” option if you DO NOT plan to automatically submit a grade from the 

SoftChalk lesson into the Blackboard gradebook. 

 

b. Copy the “LTI Hyperlink” if you DO plan to automatically submit a grade from the 

SoftChalk lesson into the Blackboard gradebook. 

20. Minimize or close SoftChalk Cloud. 

Create the Web Link to Open the Lesson in the Cloud 

Once the Hyperlink (no grade being submit 

ted to Bb gradebook) or the “LTI Hyperlink” (a grade is to be submitted to Bb gradebook) has been 

copied from the lesson stored in the Cloud, a “Web Link” needs to be created in Blackboard which uses 

the Hyperlink or the LTI Hyperlink to open the lesson stored in the Cloud. 

 

21. In Blackboard, open the course where you want to display the SoftChalk lesson.  

22. Go to the Content area/folder where you want the lesson to be displayed. 

23. Click on Build Content > Web Link 

a. Name = <whatever text you want the student to click on to launch the lesson> 

b. Use CTRL-V to paste the URL for the hyperlink or LTI hyperlink. 

c. If a grade from the SoftChalk lesson is to be automatically submitted to the Bb 

gradebook: 

i. Check the box that says “This link is to a Tool Provider”  

ii. Enable Grading = “YES.” 

iii. Check the box to Enable Grading. 

iv. Enter the total Points Possible for the lesson. 
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v. Visible to Students = “YES.” 

d. Open in New Window = “Yes” 

e. Track Number of Views = “Yes” 

f. SUBMIT 
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MISCELLANEOUS 

Re-sync SoftChalk Create with SoftChalk Cloud After a Password Change 

Periodically, you many need to change your password in SoftChalk Cloud.  Back in April 2014, Cloud 

users saw a warning sign prompting them to change their Cloud password because of a threat called 

BleedHeart.  After changing passwords in Cloud, the SoftChalk Create program cannot upload content 

because the connection no longer works.  The two programs have to be re-synced. 

 

Change your Password in SoftChalk Cloud 

1. Login to SoftChalk Cloud 

2. At the right side of the screen, click “Edit Profile.” 

3. Beside the third field (Password), click the Change link. 

4. Supply the current password. 

5. Type a new password. 

6. Re-type the new password. 

7.  

 

Re-sync Create and Cloud 

1. Complete the steps in the previous section of this manual to change the password in SoftChalk 

Cloud. 

2. Open the SoftChalk Create program. 

3. Click File>Manage Publish Accounts  

4. Click the account (probably the only one available) for SoftChalk Cloud to highlight it. 

5. Click the Edit button 

6. Remove the current password in the Password field. 

7. Type the new password which was created in the section above. 

8.  

9.  


